skip to Main Content

huawei ağ ekipmanlarında basit martini vpls uygulaması

aşağıdaki topoloji üzerinde huawei ağ ekipmanlarını kullanarak basit bir mpls martini vpls örneği yapalım.

öncelikle loopback ve ip tanımlarını sırasıyla yapalım.

sysname R1

interface GigabitEthernet0/0/0
 ip address 10.1.1.1 255.255.255.0

interface LoopBack0
 ip address 192.168.0.1 255.255.255.255
sysname R2

interface GigabitEthernet0/0/0
 ip address 10.1.1.2 255.255.255.0

interface GigabitEthernet0/0/1
 ip address 10.2.2.2 255.255.255.0

interface LoopBack0
 ip address 192.168.0.2 255.255.255.255
sysname R3

interface GigabitEthernet0/0/1
 ip address 10.2.2.1 255.255.255.0

interface LoopBack0
 ip address 192.168.0.3 255.255.255.255

tüm arayüzler aktif olduktan sonra örnekte ospf yönlendirme protokolünü kullanacağımız için yönlendiriciler üzerinde ospf leri aktif etmek için gerekli yapılandırmasını yapalım.

sysname R1
ospf 1
 area 0.0.0.0
  network 192.168.0.1 0.0.0.0
  network 10.1.1.0 0.0.0.255
sysname R2
ospf 1
 area 0.0.0.0
  network 192.168.0.2 0.0.0.0
  network 10.1.1.0 0.0.0.255
  network 10.2.2.0 0.0.0.255
sysname R3
ospf 1
 area 0.0.0.0
  network 10.2.2.0 0.0.0.255
  network 192.168.0.3 0.0.0.0

ospf de aktif olduktan sonra mpls tanımlarına başlayabiliriz. tüm yönlendiriciler de global de mpls i aktif edelim.

mpls lsr-id 192.168.0.x
mpls
mpls l2vpn
mpls ldp

sonrasında ağımızda yönlendiriciler arasındaki arayüz bağlantıları altında mpls, mpls ldp aktif ediyoruz.

interface GigabitEthernet0/0/x
 mpls
 mpls ldp

en temel kontrolleri yaptık bir sorun görülmüyor. şimdi pc1 – pc2 arasındaki haberleşmenin sağlanması için gerekli yapılandırmaya sıra geldi. öncelikle r1 den r3 , r3 den r1 doğru ldp remote tanımlarını yapmalıyız.

sysname R1
mpls ldp remote-peer ldp_peer_to_r3
 remote-ip 192.168.0.3
sysname R3
mpls ldp remote-peer ldp_peer_to_r1
 remote-ip 192.168.0.1

şimdi yapabileceğimiz bazı kontrolleri yapalım.

<R1>display  mpls interface 
Interface             Status    TE Attr   LSP Count  CRLSP Count Effective MTU
GE0/0/0               Up        Dis       4          0           1500      
<R1>
<R1>display mpls ldp session 

 LDP Session(s) in Public Network
 Codes: LAM(Label Advertisement Mode), SsnAge Unit(DDDD:HH:MM)
 A '*' before a session means the session is being deleted.
 ------------------------------------------------------------------------------
 PeerID             Status      LAM  SsnRole  SsnAge      KASent/Rcv
 ------------------------------------------------------------------------------
 192.168.0.2:0          Operational DU   Passive  0000:01:45  423/423
 192.168.0.3:0          Operational DU   Passive  0000:01:53  455/455
 ------------------------------------------------------------------------------
 TOTAL: 2 session(s) Found.
[R1]display mpls route-state 
Codes: B(BGP), I(IGP), L(Public Label BGP), O(Original BGP), U(Unknow)
--------------------------------------------------------------------------------
Dest/Mask          Next-Hop        Out-Interface              State LSP VRF Type
--------------------------------------------------------------------------------

192.168.0.1/32         127.0.0.1       InLoop0                    READY 1   0      I
192.168.0.2/32         10.1.1.2        GE0/0/0                    READY 2   0      I
192.168.0.3/32         10.1.1.2        GE0/0/0                    READY 2   0      I
[R1]display mpls lsp 
-------------------------------------------------------------------------------
                 LSP Information: LDP LSP
-------------------------------------------------------------------------------
FEC                In/Out Label  In/Out IF                      Vrf Name       
192.168.0.2/32         NULL/3        -/GE0/0/0                                     
192.168.0.2/32         1028/3        -/GE0/0/0                                     
192.168.0.3/32         NULL/1025     -/GE0/0/0                                     
192.168.0.3/32         1029/1025     -/GE0/0/0                                     
192.168.0.1/32         3/NULL        -/-             

şimdi vsi ları oluşturalım. burada dikkat edilmesi gereken en önemli nokta vsi-id lerin aynı olması gerektiğidir.

sysname R1
vsi vsi_for_pc static
 pwsignal ldp
  vsi-id 100
  peer 192.168.0.3
sysname R3
vsi vsi_for_pc static
 pwsignal ldp
  vsi-id 100
  peer 192.168.0.1

son aşamaya gelmiş olduk. bilgisayarların bağlı arayüzler için tanımları da tapalım.

sysname R1
interface Ethernet0/0/1
 l2 binding vsi vsi_for_pc
sysname R3
interface Ethernet0/0/1
 l2 binding vsi vsi_for_pc

tüm yapılandırmaları tamamlamış olduk. şimdi bilgisayarlara ip leri girerek erişim kontrolleri yapalım. bilgisayarlarda ağ geçidi olarak karşı bilgisayarın iplerini girelim.

PC>ping 100.1.1.2

Ping 100.1.1.2: 32 data bytes, Press Ctrl_C to break
From 100.1.1.2: bytes=32 seq=1 ttl=128 time=94 ms
From 100.1.1.2: bytes=32 seq=2 ttl=128 time=156 ms
From 100.1.1.2: bytes=32 seq=3 ttl=128 time=62 ms
From 100.1.1.2: bytes=32 seq=4 ttl=128 time=94 ms
From 100.1.1.2: bytes=32 seq=5 ttl=128 time=110 ms

--- 100.1.1.2 ping statistics ---
  5 packet(s) transmitted
  5 packet(s) received
  0.00% packet loss
  round-trip min/avg/max = 62/103/156 ms

yönlendiricilere ait yapılandırmaların tam hali aşağıda yer almaktadır.

sysname R1

mpls lsr-id 192.168.0.1
mpls
mpls l2vpn
mpls ldp

vsi vsi_for_pc static
 pwsignal ldp
  vsi-id 100
  peer 192.168.0.3

mpls ldp remote-peer ldp_peer_to_r3
 remote-ip 192.168.0.3

interface Ethernet0/0/1
 l2 binding vsi vsi_for_pc

interface GigabitEthernet0/0/0
 ip address 10.1.1.1 255.255.255.0
 mpls
 mpls ldp

interface LoopBack0
 ip address 192.168.0.1 255.255.255.255

ospf 1
 area 0.0.0.0
  network 192.168.0.1 0.0.0.0
  network 10.1.1.0 0.0.0.255
sysname R2

mpls lsr-id 192.168.0.2
mpls
mpls ldp

interface GigabitEthernet0/0/0
 ip address 10.1.1.2 255.255.255.0
 mpls
 mpls ldp

interface GigabitEthernet0/0/1
 ip address 10.2.2.2 255.255.255.0
 mpls
 mpls ldp

interface LoopBack0
 ip address 192.168.0.2 255.255.255.255

ospf 1
 area 0.0.0.0
  network 192.168.0.2 0.0.0.0
  network 10.1.1.0 0.0.0.255
  network 10.2.2.0 0.0.0.255
sysname R3

mpls lsr-id 192.168.0.3
mpls
mpls l2vpn
mpls ldp

vsi vsi_for_pc static
 pwsignal ldp
  vsi-id 100
  peer 192.168.0.1

mpls ldp remote-peer ldp_peer_to_r1
 remote-ip 192.168.0.1

interface Ethernet0/0/1
 l2 binding vsi vsi_for_pc
 
interface GigabitEthernet0/0/1
 ip address 10.2.2.1 255.255.255.0
 mpls
 mpls ldp

interface LoopBack0
 ip address 192.168.0.3 255.255.255.255

ospf 1
 area 0.0.0.0
  network 10.2.2.0 0.0.0.255
  network 192.168.0.3 0.0.0.

Alcatel Yönlendiricilerde SDP ( Service Distribution Path ) oluşturulması

Açılımı Service Distribution Path – Servis Dağıtım Yolu olan SDP yi cihazlar arasında trafiğin taşındığı sanal yol olarak tanımlayabiliriz.

SDP ler hakkında bilinmesi gereken en önemli bilgiler

– Cihazlar arasında SDP oluşturulurken gre veya mpls kapsülleme tiplerinden biri kullanılabilir.
– SDPler tek taraflı trafik taşımaktadır. nodelar arasında trafik taşımak için B_to_A ve A_to_B şeklinde SDP ler oluşturulmalıdır.
– SDP lerin minimum MTU değerlerine dikkat edilmelidir. MPLS kullanılacak 22 byte , GRE kullanılacaksa 46 byte ilave headerlar eklenecektir. 576 ile 9194 arasında bir mtu kullanılabilir.
– Her SDP için tek bir ID üretilir.
– Farklı servisler tek bir SDP yi kullanabilirler
– Tanımlamalarda yönlendirici IP adresleri kullanılır.

şeklinde sıralanabilir. Detay konusunda Alcatel dökümanlarına bakılması faydalı olacaktır.

Bu bilgilere göre oluşturulacak temel SDP konfigürasyonu aşağıdaki yapıda olacaktır.

config>service>sdp yonlendiri_ozel_sdp_id [gre | mpls]  create
description "yonlendiriciA-yonlendiriciB"
far-end uzak_uc_yonlendirici_ip_adresi
keep-alive
ldp (sadece MPLS SDP lerinde - LDP kullanılacaksa)
lsp lsp-name [lsp-name]  (sadece MPLS SDP lerinde - LSP kullanılacaksa)
signaling {off|tldp}
path-mtu mtu_degeri
no shutdown

şimdi değerleri yerine yazalım

GRE için SDP oluşturma

config>service# sdp 100 gre create
config>service>sdp# description “A to B GRE”
config>service>sdp# far-end “10.10.10.2”
config>service>sdp# path-mtu 4462
config>service>sdp# no shutdown

MPLS (LSP) için SDP oluşturma.

config>service# sdp 101 mpls create
config>service>sdp# description “A to B MPLS LSP”
config>service>sdp# far-end “10.10.10.2”
config>service>sdp# lsp "a_to_b_lsp"
config>service>sdp# path-mtu 4462
config>service>sdp# no shutdown

MPLS (LDP) için SDP oluşturma.

config>service# sdp 102 mpls create
config>service>sdp# description “A to B MPLS LDP”
config>service>sdp# far-end “10.10.10.2”
config>service>sdp# ldp 
config>service>sdp# path-mtu 4462
config>service>sdp# no shutdown

Alcatel-Lucent 7450 Ethernet Service Switch (ESS) Media Dependent Adapter-XP (MDA-XP)

 

Maximum Ports per Alcatel -Lucent 7450 ESS Chassis
Part number  Part Image Part Name  Description ESS-1 ESS-6/6V ESS-7 ESS-12
3HE03616AA  20-port GigE MDA-XP – SFP 20-port 10/100/1000BASE-TX MDA-XP 7450 ESS 20-port 10/100/1000BASE Ethernet MDA-XP with RJ-45 connectors. 40 160 200 400
3HE03615AA  20-port GigE MDA-XP – Copper 20-port GigE MDA-XP 7450 ESS 20-port 1000BASE Ethernet MDA-XP. Accepts up to twenty (20) GigE-xx optical SFP modules. For 10/100/1000BASE-TX operation, GigE TX SFPs are supported. 40 160 200 400
3HE03614AA  10-port GigE MDA-XP – SFP 10-port GigE MDA-XP 7450 ESS 10-port 1000BASE Ethernet MDA-XP. Accepts up to ten (10) GigE-xx optical SFP modules. For 10/100/1000BASE-TX operation, GigE TX SFPs are supported. 20 80 100 200
3HE03688AA  4-port 10GigE MDA-XP – XFP 4-port 10GigE MDA-XP 7450 ESS 4-port 10GBASE oversubscribed Ethernet MDA-XP. Accepts up to four (4) XFP 10GigE optical modules and supports WAN/LAN PHY operation. 8 32 40 80
3HE03687AA  2-port 10GigE MDA-XP – XFP 2-port 10GigE MDA-XP 7450 ESS 2-port 10GBASE Ethernet MDA-XP. Accepts up to two (2) XFP 10GigE optical modules and supports WAN/LAN PHY operation. 4 16 20 40
3HE04273AA  1-port 10GigE MDA-XP – XFP 1-port 10GigE MDA-XP 7450 ESS 1-port 10GBASE Ethernet MDA-XP. Accepts one (1) XFP 10GigE optical module and supports WAN/LAN PHY operation. 2 8 10 20

Huawei NE40E Evrensel Hizmet Yönlendirici

huawei ne40e evrensel hizmet yönlendiricilerinin karşılaştırma tablosu aşagıdaki gibidir.


 

Öznitelik NE40E-X16 NE40E-X8 NE40E-X3
Anahtarlama
Kapasitesi
12.58 Tbps 7.08 Tbps 1.08T bps
İletme
Performansı
3200 Mpps 1600 Mpps 300 Mpps
Yuva Sayısı 2 MPUs(1:1 yedek), 4 SFUs(3+1 yedek) ve 16 LPUs dahil 22 yuva 2 SRUs(1:1 yedek), 1 SFUs(2+1 yedek) ve 8 LPUs dahil 11 yuva 2 MPUs(1:1 yedek) ve 3 LPUs dahil 5 yuva
Boyut
(G×D×Y)
442mm × 650mm × 1420mm (32 U) 442mm × 650mm × 620mm (14 U) 442mm × 650 mm × 175mm (DC 4 U)

442mm × 650 mm × 220mm (AC 5 U)

Maksimum
güç
tüketimi
5360 W (40 G)

6500 W (100 G)

2800 W (40 G)

3300 W (100 G)

1100 W
Tam yapılandırmadaki ağırlık 267 kg 130 kg 41 kg (DC)

51 kg (AC)

Arayüz
Tipi
10GE- LAN /WAN GE/FE

OC-192c/STM-64c POS OC-48c/STM-16c POS

OC-12c/STM-4c POS OC-3c/STM-1c POS

Kanalize OC-3/STM-1 OC-3c/STM-1c ATM

OC-12c/STM-4c ATM E3/CT3

CE1/CT1 E1/T1

IPv4 Statik yönlendirme protokolü ve RIP, OSPF, IS-IS ve BGP-4 gibi IPv4 dinamik yönlendirme protokollerini destekler.
IPv6 IPv4’ten IPv6’ya geçiş için çeşitli teknolojileri destekler: manüel tünel yapılandırmaları, otomatik tünel yapılandırmaları, IPv6-IPv4 (6-4) tünelleme, Genel Yönlendirme Kapsüllendirmesi (GRE) tünelleme ve Tesis İçi Otomatik Tünel Adresleme Protokolü (ISATAP) tünelleme.

IPv6 üzerinden IPv4 tünelleme ve IPv6 Servis Sağlayıcı Uç Router (6PE)’i destekler.

IPv6 statik yönlendirme protokolünü destekler.

RIP Gelecek Nesil (RIPng), OSPFv3, IS-ISv6 ve BGP4+ gibi IPv6 dinamik yönlendirme protokollerini destekler.

IPv6 komşu saptama ve yol Maksimum İletim Birimi (PMTU) saptamayı destekler.

İletim Kontrol Protokolü 6. Sürüm (TCP6), ping IPv6, traceroute IPv6, soket IPv6, statik IPv6 Etki Alanı Adı Sistemi (DNS), IPv6 DNS sunucusunu belirleme, Küçük Dosya Transfer Protokolü (TFTP) IPv6 istemci ve IPv6 politika tabanlı yönlendirmeyi destekler.

İnternet Kontrol Mesaj Protokolü 6. Sürüm (ICMPv6) Yönetim Bilişim Tabanı (MIB), Kullanıcı Datagram Protokolü 6. Sürüm (UDP6) MIB, TCP6 MIB ve IPv6 MIB’i destekler.

MPLS TE üzerinden LDP, VPLS, H-VPLS, VPN’de politika tabanlı yönlendirmeyi destekler.

Martini ya da Kompella modunda MPLS L2VPN’leri destekler.

VLL/VPLS erişimli L3VPN’leri destekler.

QinQ, MPLS/BGP L3VPN ve AS arası VPN Seçenek A/B/C’yi destekler.

Asenkron Transfer Modu (ATM) E1, ATM Üzerinden Ters Çoklama (IMA) ve Zaman Paylaşımlı Çoklama (TDM) PWE3’ü destekler.

MPLS-TP’yi destekler

Katman 2
özelliği
IEEE802.1q, IEEE802.1p, IEEE 802.3ad ve IEEE 802.1ab’yi destekler.

Spanning Tree Protokolü (STP), Hızlı Spanning Tree Protokolü (RSTP), Çoklu Spanning Tree Protokolü (MSTP), RRPP, DHCP+, VLAN anahtarlama ve kullanıcı ilişkilendirmeyi destekler.

Güvenilirlik BGP GR, IS-IS GR ve OSPF GR’yi destekler.

LDP GR, Kaynak Koruma Protokolü (RSVP) GR ve Durmadan İletmeyi (NSF) destekler.

VLL/VPLS/L3VPN GR/NSF’yi destekler.

Çok noktaya NSF’yi destekler.

BGP/IS-IS/OSPF/LDP/RSVP-TE/PIM/ISSU Durmadan Yönlendirmeyi (NSR) destekler.

Servis Kesintisiz Yazılım Yükseltmeyi (ISSU) destekler.

Ağ İçi Yönlendirme Protokolleri (IGP), BGP ve çok noktaya yönlendirmeyi hızlı yakınsamayı destekler.

IP/LDP/VPN/TE/VLL FRR’yi destekler.

IP Oto FRR’yi destekler.

Statik yönlendirme protokolü ve IS-IS, RSVP, LDP, TE, Label Switched Path (LSP), PW, OSPF, BGP, VRRP, PIM ve RRPP gibi protokoller için BFD’yi destekler.

RRPP’yi destekler.

MPLS OAM ve Ethernet OAM, Y.1731’i destekler.

Hizmet yönlendiricleri yedekleme, PW yedekleme ve PWE3 uçtan uca korumayı destekler.

E-Ana Hat, E-APS, E-STP’yi destekler.

QoS Ağırlıklı Randomize Erken Algılama (WRED), maksimum sekiz CT’li DS-TE kapasite, beş düzeyli H-QoS programlama, VLL/PWE3 QoS ve MPLS H-QoS’yi destekler.

Last mile QoS’yi destekler.

IPoE erişimli kullanıcıların çok noktaya kopyalanmasını destekler.

Çok noktaya yayın IGMPv1, IGMPv2, IGMPv3, IGMP trafik gözetleme, çok noktaya VPN ve IPv6 çok noktaya yayını destekler.

Statik çok noktaya yönlendirmeleri destekler.

Çok noktaya yönlendirme protokollerini destekler: PIM-DM, PIM-SM, PIM-SSM, Çok noktaya yayın kaynağı Keşif Protokolü (MSDP) ve Çoklu protokol BGP (MBGP).

Hem çok noktaya yayın hem de TE kurulumunu destekler.

Çok noktaya CAC’ı destekler.

Güvenlik ACL filtreleme, URPF, GTSM, DHCP Trafik Gözetlemeyi destekler.

Anti-ARP saldırısı、anti-DOS saldırısını destekler.

MAC adres sınırlama, MAC ile IP arasında bağlantı kurmayı destekler.

SSH, SSH v2’yi destekler.

NetStream’i destekler.

IPSec’i destekler.

Çevre

gereksinimleri

Uzun süreli ortam sıcaklığı: 0℃ ila 45℃

Kısa süreli ortam sıcaklığı: –5℃ ila +55℃

Uzun süreli bağıl nem: %5 ila %85, yoğuşmasız

Kısa süreli bağıl nem: %0 ila %95, yoğuşmasız

Çalışma yüksekliği: 3000 metreden alçak

 

kaynak: huawei.com

huawei mpls : display diagnostic-information

huawei mpls lerde

display startup
display alarm all
display voltage slot 1
display temperature slot 1
display power
display cpu-usage
display cpu-usage slave
display cpu-usage slot 1
display memory-usage
display memory-usage slave
display memory-usage slot 1
display current-configuration

komutları ile sistemin durumu hakkında bilgiler alınabilir. her bir komut farklı zamanlarda kesin işe yarayacaktır ancak acil bir durumda tüm komutları tek tek çalıştırmak zaman kaybı olabilir. bu yüzden dolayı acil durumlar kullanılmak üzere aşağıdaki komut dizisi kullanılabilir.

>display diagnostic-information acildurumverisi_01012012.txt

bu komutu kullanmak zorunda kalınmaması dileğiyle…

huawei s3000 serisi switch

şirketinize IT yatırımları yaparken cisco, alcatel gibi firmaların yüksek fiyatlarından bıktıysanız ve alternatif arıyorsanız huawei switch ler imdadınıza yetişebilir. gerçi huawei nin sicili pek temiz sayılmaz ama işinizi görecektir.

s3000 serisi bir cihaz için temel konfigürasyonunu beraber yapalım. S3352P-EI-48S e ait görsel aşağıda görülmektedir.

 

 

konfigürasyon modunu aktif edelim ve switchimizin adını değiştirelim

<Quidway>system-view
[Quidway]sysname Customer_A
[Customer_A]

switchimiz için yönetim ayarlarını yapalım. yönetim için  99 vlanını kullanacağız… vlanı 99  u  oluşturalım

[Customer_A]vlan 99
[Customer_A-vlan99]quit 

99 vlan için ip tanımlamalarını yapalım.

[Customer_A]interface Vlanif 99
[Customer_A-Vlanif99]ip address 10.0.0.1 30
[Customer_A-Vlanif99]quit

switchimiz üzerinde yer alan gibabitethernet arayüzlerinen bir tanesini trunk olarak olarak tanımlayalım ve tüm vlan için kullanılabilir yapalım.

[Customer_A]interface GigabitEthernet 0/0/1
[Customer_A-GigabitEthernet0/0/1]undo port default vlan
[Customer_A-GigabitEthernet0/0/1]port link-type trunk
[Customer_A-GigabitEthernet0/0/1]port trunk allow-pass vlan all
[Customer_A-GigabitEthernet0/0/1]quit

48 portlu bir switch kullanıyorduk. bu yüzden 48. portu yönetim içinde aktif edelim. diğer portlar için yönetime erişim vermeyeceğiz.

[Customer_A]interface Ethernet 0/0/48
[Customer_A-Ethernet0/0/48]undo port default vlan
[Customer_A-Ethernet0/0/48]port link-type trunk
[Customer_A-Ethernet0/0/48]port trunk allow-pass vlan all
[Customer_A-Ethernet0/0/48]quit

iş ağımızda kullanım için 100 vlanını tercih ettiğimizi varsayarak 100 vlanını oluşturalım.

[Customer_A]vlan 100
[Customer_A-vlan100]quit

switch üzerinde yer alan 0/0/1 ve 0/0/2 ethernet portlarını vlan 100 kullanımı için aktif edelim

[Customer_A]interface Ethernet 0/0/1
[Customer_A-Ethernet0/0/1]port link-type access
[Customer_A-Ethernet0/0/1]port default vlan 100
[Customer_A-Ethernet0/0/1]quit

[Customer_A]interface Ethernet 0/0/2
[Customer_A-Ethernet0/0/2]port link-type access
[Customer_A-Ethernet0/0/2]port default vlan 100
[Customer_A-Ethernet0/0/2]quit

şimdide en temel route imizi yazalım

[Customer_A] ip route-static 0.0.0.0 0 10.0.0.2 

temel konfigürasyon işte bu kadar..

 

Back To Top
X