skip to Main Content

huawei network ekipmanlarında alarm nedeniyle kapanmış olan arayüzlerin açılması

bir çok router ve switchte herhangi bir arayüz üzerindeki servislerde veya portta fiziksel hataların tespiti ile o arayüz üzerindeki servislerin / trafiğin daha fazla etkilenmemesi için arayüzü kapatabilirsiniz.

huawei network ekipmanlarında benzer şekilde kapatılmış arayüzlerin tespitini yapmak için farklı yöntemler mevcut.

display trapbuffer ve display logbuffer ile log incelemesi yapılabilir. display interface brief ile loop v.b. durumlar gözlemlenebilir.

en temel olanı ise arayüze doğrudan bakmak.

[test_router-GigabitEthernet1/0/1]display interface GigabitEthernet 1/0/1
GigabitEthernet1/0/1 current state : Port-alarm DOWN
Line protocol current state : DOWN
Link quality grade : --
Description:test-interface
Route Port,The Maximum Transmit Unit is 9212
Internet Address is 11.12.13.17/31
IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is bc3d-39ef-f236
The Vendor PN is MTRS-02X13-G
The Vendor Name is HG GENUINE
Port BW: 10G, Transceiver max BW: 10G, Transceiver Mode: SingleMode
WaveLength: 1310nm, Transmission Distance: 10km
Rx Power: -2.09dBm, Warning range: [-14.40,  0.50]dBm
Tx Power: -40.00dBm, Warning range: [-8.20,  0.50]dBm
Loopback:none, LAN full-duplex mode, Pause Flowcontrol:Receive Enable and Send Enable
Last physical up time   : 2020-08-22 14:27:21 UTC+03:00
Last physical down time : 2020-08-22 14:27:23 UTC+03:00
Current system time: 2020-08-22 17:31:33+03:00
Statistics last cleared:2020-08-22 16:32:36
    Last 10 seconds input rate: 0 bits/sec, 0 packets/sec
    Last 10 seconds output rate: 0 bits/sec, 0 packets/sec
    Input: 0 bytes, 0 packets
    Output: 0 bytes, 0 packets
    Input:
      Unicast: 0 packets, Multicast: 0 packets
      Broadcast: 0 packets, JumboOctets: 0 packets
      CRC: 0 packets, Symbol: 0 packets
      Overrun: 0 packets, InRangeLength: 0 packets
      LongPacket: 0 packets, Jabber: 0 packets, Alignment: 0 packets
      Fragment: 0 packets, Undersized Frame: 0 packets
      RxPause: 0 packets
    Output:
      Unicast: 0 packets, Multicast: 0 packets
      Broadcast: 0 packets, JumboOctets: 0 packets
      Lost: 0 packets, Overflow: 0 packets, Underrun: 0 packets
      System: 0 packets, Overrun: 0 packets
      TxPause: 0 packets
      Unknown Vlan: 0 packets
    Input bandwidth utilization  :    0%
    Output bandwidth utilization :    0%

veya

[test_router-GigabitEthernet1/0/1]display interface phy-option GigabitEthernet 1/0/1
GigabitEthernet1/0/1
Port Physical Status    :DOWN
Physical Down Reason    :PORT_ALARM_DOWN
Loopback                :none
Duplex mode             :full-duplex
Pause Flowcontrol:
Receive                 :Enable
Send                    :Enable
SFP imformation:
The Vendor PN is MTRS-02X13-G    
The Vendor Name is HG GENUINE      
Port BW: 10G, Transceiver max BW: 10G, Transceiver Mode: SingleMode
WaveLength: 1310nm, Transmission Distance: 10km
Rx Power: -2.08dBm, Warning range: [-14.40,  0.50]dBm
Tx Power: -40.00dBm, Warning range: [-8.20,  0.50]dBm

yukarıdaki örneklerde

GigabitEthernet1/0/1 current state : Port-alarm DOWN
Tx Power: -40.00dBm, Warning range: [-8.20,  0.50]dBm

Port Physical Status    :DOWN
Physical Down Reason    :PORT_ALARM_DOWN

arayüzün alarm nedeniyle down olduğu ve doğal olarak tx = -40 olduğu görülmektedir.

bu örnekte arayüz altında hata olmadığı görülüyor. alarmlar temizlenmiş v.b. olabilir. arayüzün neden kapanmış olduğuna bakalım.

[test_router-GigabitEthernet1/0/1]display  port-error-info  interface GigabitEthernet 1/0/1
GigabitEthernet1/0/1 port-error information
================================================================================
 input-error                            | output-error
--------------------------------------------------------------------------------
 trap enable    : Yes                   | trap enable    : Yes
 trigger down   : No                    | trigger down   : No 
 alarm status   : No                    | alarm status   : No 
 threshold high : 1000                  | threshold high : 1000
 threshold low  : 100                   | threshold low  : 100
 interval       : 10    sec.            | interval       : 10    sec.
 stat(h)        : 0                     | stat(h)        : 0
 stat(l)        : 0                     | stat(l)        : 0
================================================================================
 crc-error                              | symbol-error
--------------------------------------------------------------------------------
 trap enable    : Yes                   | trap enable    : Yes
 trigger down   : Yes                   | trigger down   : No 
 alarm status   : No                    | alarm status   : No 
 threshold high : 3                     | threshold high : 1000
 threshold low  : 3                     | threshold low  : 100
 percent        : 0                     | N/A            : N/A
 interval       : 10    sec.            | interval       : 10    sec.
 stat(h)        : 0                     | stat(h)        : 0
 stat(l)        : 0                     | stat(l)        : 0
[test_router-GigabitEthernet1/0/1]

arayüz için 4 alarm kontrolün aktif olduğu görülmektedir. çıktıya baktığımızda

crc-error 
trap enable    : Yes 
trigger down   : Yes 

crc hataları nedeniyle tetiklendiği görülmektedir. ilk önce portun kapanmasına neden olan alarmlar giderilmeli. alarm nedeni giderildikten sonra yapılması gereken için port üzerindeki alarmların clear edilmesi gerekmekte.

bunun nasıl yapılacağını

huawei routerlarda interface üzerinde alarm sayısını sıfırlama

başlıklı yazıda yazmıştım. alarmları sıfırladıktan sonra arayüzün aktif hala gelmesi gerekiyor. eğer aktif olmaz ise portu restart yapmak faydalı olabilir.

[test_router-GigabitEthernet1/0/1]restart

huawei ağ ekipmanlarında arayüzlerin lan/wan ayarı

huawei ağ ekipmanlarında destekleyen arayüzlerde wan ve lan modu ayarı yapılabilmektedir.

[fcicek-route]display  device  pic-status
Pic-status information in Chassis 1:
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
SLOT PIC Status     Type                   Port_count Init_result   Logic_down 
1    0   Registered LAN_WAN_2x10GF_B_CARD  2          SUCCESS       SUCCESS    
1    1   Registered ETH_24xGF_B_CARD       24         SUCCESS       SUCCESS    
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

örnekteki yönlendirici de 1 tane lpuf kartı ve 2 tane pic kartı olduğu görülmektedir. 1. pic 2 tane 10G arayüze sahip bir kartıdır.. bu arayüzler adında anlaşılabileceği üzere lan/wan modunda kullanılabilir.

huaweide lan modu öntanımlı konfigüasyon olarak gelmektedir.

örnek olması için şimdi 1/0/0 arayüzünün modunu değiştirelim.

[fcicek-route-GigabitEthernet1/0/0]display this
interface GigabitEthernet1/0/0
undo shutdown
eth-trunk 1
undo dcn

[fcicek-route-GigabitEthernet1/0/0]set transfer-mode ?
  lan  LAN interface
  wan  WAN interface
          

[fcicek-route-GigabitEthernet1/0/0]set transfer-mode wan
Error: Has configurations or the undo-shutdown state port, please clear them first.

yukarıda başarısız mod değişikliği teşebbüsünden görüleceği üzere arayüz altında konfigürasyon olmaması ve portun kapalı olması gerekmektedir. arayüz altındaki konfigürasyonu kaldırıp wan moduna alalım. mod değişikliği için “set transfer-mode ” komut dizilimini kullanıyoruz.

[fcicek-route-GigabitEthernet1/0/0]set transfer-mode wan
Info: Switch wan mode is succeed.
                        
[fcicek-route-GigabitEthernet1/0/0]display this                         
interface GigabitEthernet1/0/0
set transfer-mode wan
shutdown
undo dcn

huawei routerlarda interface üzerinde alarm sayısını sıfırlama

huawei routerlarda display komutu ile interface detaylarına baktığımızda interface üzerinde meydana gelen hatalarıda görebiliyoruz. bu hatalar sürekli artımlı şekilde devam etmektedir.

[fcicek_test_router-GigabitEthernet1/0/0]display interface GigabitEthernet 1/0/0
GigabitEthernet1/0/0 current state : UP
Line protocol current state : DOWN
Link quality grade : GOOD
Description:sube_a
Route Port,The Maximum Transmit Unit is 1500
Internet protocol processing : disabled
IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is aaaa-aaaa-aaaa
The Vendor PN is RTXM191-400
The Vendor Name is WTD
Port BW: 1G, Transceiver max BW: 1G, Transceiver Mode: SingleMode
WaveLength: 1310nm, Transmission Distance: 10km
Rx Power: -6.51dBm, Warning range: [-20.00, -3.00]dBm
Tx Power: -5.53dBm, Warning range: [-9.00, -3.00]dBm
Loopback:none, full-duplex mode, negotiation: enable, Pause Flowcontrol:Receive Enable and Send Enable
Last physical up time   : 2016-07-19 09:41:00 UTC+02:00 DST
Last physical down time : 2016-07-19 09:39:46 UTC+02:00 DST
Current system time: 2016-08-13 06:11:06+02:00
Statistics last cleared:never
    Last 10 seconds input rate: 6816 bits/sec, 7 packets/sec
    Last 10 seconds output rate: 5632 bits/sec, 5 packets/sec
    Input: 144440952031 bytes, 928751872 packets
    Output: 335843205389 bytes, 872370561 packets
    Input:
      Unicast: 855698710 packets, Multicast: 53900340 packets
      Broadcast: 19152822 packets, JumboOctets: 12274608 packets
      CRC: 100 packets, Symbol: 0 packets
      Overrun: 0 packets, InRangeLength: 0 packets
      LongPacket: 0 packets, Jabber: 0 packets, Alignment: 0 packets
      Fragment: 0 packets, Undersized Frame: 0 packets
      RxPause: 0 packets
    Output:
      Unicast: 872368829 packets, Multicast: 0 packets
      Broadcast: 1732 packets, JumboOctets: 137186914 packets
      Lost: 0 packets, Overflow: 0 packets, Underrun: 0 packets
      System: 0 packets, Overrun: 0 packets
      TxPause: 0 packets
    Input bandwidth utilization  :    0%
    Output bandwidth utilization :    0%

eğer bir interfacede hatayı gidermeye yönelik bir işlem yaptıysanız interface üzerindeki hataları sıfırlamak her zaman işimizi kolaylaştıracaktır.

yukarıda örnekte 1/0/0 interfaceinde 100 adet CRC hatası geldiği görülmektedir. bunu sıfırlamak için interface içine konfigürasyon modda girerek port-alarm komutunu kullanıyoruz.

[fcicek_test_router-GigabitEthernet1/0/0]port-alarm clear ?
  crc-error     CRC error alarm
  input-error   Input error alarm
  output-error  Output error alarm
  pause-frame   Pause Frame alarm
  symbol-error  Symbol error alarm

yukarıda görüldüğü gibi bu interface üzerinde 5 adet hatanın değerlerini sıfırlayabiliyoruz.

bizim hatalarımız crc hataları olduğu için crc hatalarının sayısını sıfırlamak için aşagıdaki komutu tamamlamamız gerekecektir

[fcicek_test_router-GigabitEthernet1/0/0]port-alarm clear crc-error

 

örnekler üzerinden temel SNMP

snmp desteğine sahip cihazlardan veri alınması, yorumlanması ve cihazlara ait mib ve oid değerlerinin önemi kısaca anlatmaya çalışalım. teoriye girmeden uygulamalı olarak net-snmp kullanarak alcatel omniswitchler üzerinden ufak bir iki örnek yapalım.

burada unutulmaması gereken nokta kullanacağımız cihaza ait gerekli snmp ayarlarını yapmış olmamız gerekmektedir. örneğimizde snmp adında public de tam yetkili bir kullanıcı oluşturdum. kısaca snmp ile herşey serbest durumda.

ilk önce bağlantı yapabiliyormuyuz bir deneyelim.

$ snmpwalk -v 2c -c public 10.0.0.10 system
SNMPv2-MIB::sysDescr.0 = STRING: Alcatel-Lucent OS6850-U24X 6.4.4.604.R01::evenugop Service Release, October 09, 2013.
SNMPv2-MIB::sysObjectID.0 = OID: SNMPv2-SMI::enterprises.6486.800.1.1.2.1.7.1.10
DISMAN-EVENT-MIB::sysUpTimeInstance = Timeticks: (2836626900) 328 days, 7:31:09.00
SNMPv2-MIB::sysContact.0 = STRING: Alcatel-Lucent, http://alcatel-lucent.com/wps/portal/enterprise
SNMPv2-MIB::sysName.0 = STRING: alcatel_test_switch
SNMPv2-MIB::sysLocation.0 = STRING: Unknown
SNMPv2-MIB::sysServices.0 = INTEGER: 78                                                                                                           

testimiz başarılı oldu ve cihaza ait temel bilgileri getirmiş oldu. buradan cihazımızın 6850 ve aos 6.4.4 çalıştırdığını ögrenmiş olduk.

https://service.esd.alcatel-lucent.com/portal/page/portal/EService/product_specific_support_media?p=OmniSwitch_6850___6850E

adresinden cihaza ait mib dosyasını indirebilir ve buradan ögrendiğimiz bilgilerle daha özel bilgilere artık ulaşabiliriz.

şimdi switch üzerindeki arayüzlerin durumunu ögrenelim

$ snmpwalk -v 2c -c public 10.0.0.10 1.3.6.1.2.1.2.2.1.7
IF-MIB::ifAdminStatus.1001 = INTEGER: up(1)
IF-MIB::ifAdminStatus.1002 = INTEGER: down(2)
IF-MIB::ifAdminStatus.1003 = INTEGER: up(1)
IF-MIB::ifAdminStatus.1004 = INTEGER: up(1)
IF-MIB::ifAdminStatus.1005 = INTEGER: up(1)
IF-MIB::ifAdminStatus.1006 = INTEGER: up(1)
IF-MIB::ifAdminStatus.1007 = INTEGER: down(2)
IF-MIB::ifAdminStatus.1008 = INTEGER: down(2)
IF-MIB::ifAdminStatus.1009 = INTEGER: down(2)
IF-MIB::ifAdminStatus.1010 = INTEGER: up(1)
IF-MIB::ifAdminStatus.1011 = INTEGER: down(2)
IF-MIB::ifAdminStatus.1012 = INTEGER: down(2)
IF-MIB::ifAdminStatus.1013 = INTEGER: down(2)
IF-MIB::ifAdminStatus.1014 = INTEGER: down(2)
IF-MIB::ifAdminStatus.1015 = INTEGER: down(2)
IF-MIB::ifAdminStatus.1016 = INTEGER: down(2)
IF-MIB::ifAdminStatus.1017 = INTEGER: up(1)
IF-MIB::ifAdminStatus.1018 = INTEGER: down(2)
IF-MIB::ifAdminStatus.1019 = INTEGER: down(2)
IF-MIB::ifAdminStatus.1020 = INTEGER: down(2)
IF-MIB::ifAdminStatus.1021 = INTEGER: down(2)
IF-MIB::ifAdminStatus.1022 = INTEGER: down(2)
IF-MIB::ifAdminStatus.1023 = INTEGER: down(2)
IF-MIB::ifAdminStatus.1024 = INTEGER: down(2)
IF-MIB::ifAdminStatus.1025 = INTEGER: down(2)
IF-MIB::ifAdminStatus.1026 = INTEGER: down(2)
IF-MIB::ifAdminStatus.1027 = INTEGER: down(2)
IF-MIB::ifAdminStatus.1028 = INTEGER: down(2)
IF-MIB::ifAdminStatus.13600001 = INTEGER: up(1)
IF-MIB::ifAdminStatus.13604098 = INTEGER: up(1)
IF-MIB::ifAdminStatus.13604099 = INTEGER: up(1)
IF-MIB::ifAdminStatus.40000001 = INTEGER: up(1)

listede switch üzerindeki tüm arayüzlerin admin up/down durumları görülmektedir. bilirli bir arayüze bakmak istiyorsak : örnek olarak 4.port

$ snmpwalk -v 2c -c public 10.0.0.10 1.3.6.1.2.1.2.2.1.7.1004
IF-MIB::ifAdminStatus.1004 = INTEGER: up(1)


$ snmpget -v 2c -c public 10.0.0.10 1.3.6.1.2.1.2.2.1.7.1004
IF-MIB::ifAdminStatus.1004 = INTEGER: up(1)

seçeneklerinden birini kullanacağız. aynı sorgulamayı switch üzerinden de gerçekleştirelim.

alcatel_test_switch-> show interfaces 1/4 port 
Legends: WTR - Wait To Restore
         #   - WTR Timer is Running & Port is in wait-to-restore state
         *   - Permanent Shutdown

Slot/    Admin     Link    Violations  Recovery   Recovery      WTR            Alias
Port     Status   Status                 Time       Max        (sec)
------+----------+---------+----------+----------+----------+----------+-----------------------------------------
  1/4    enable      down      none           300         10          0 ""

snmpwalk ve snmpget ile durum bilgisini getirmeyi ögrendik. iki komut arasındaki en temel fark snmpget ile nokta atışı yaparken snmpwalk ile ağacın alt dallarınada bakabiliyoruz.

mevcut bir veriyi nasıl değiştireceğiz sorusunun cevabı ise snmpset komutunda yatıyor

cihaz üzerinden

alcatel_test_switch-> interfaces 1/4 admin up

komutu ile gerçekleştirdiğimiz işlem için

$ snmpset -v 2c -c public 10.0.0.10 1.3.6.1.2.1.2.2.1.7.1004 i 1
IF-MIB::ifAdminStatus.1004 = INTEGER: up(1)

aynı port için

alcatel_test_switch-> interfaces 1/4 admin down 

komutu ile gerçekleştirdiğimiz işlem için

$ snmpset -v 2c -c public 10.0.0.10 1.3.6.1.2.1.2.2.1.7.1004 i 2
IF-MIB::ifAdminStatus.1004 = INTEGER: down(2)

yapısını kullanıyoruz. temelde olay bu kadar basit. snmp ile cihaz yönetimi konusunda temel mantığı uygulamalı olarak umarım anlatabilmişimdir. buradaki esas mantık cihazdaki mib yapısını iyi bilmek. bunun önemi anlamak için ufak bir örnek daha yapalım.

alcatel_test_switch-> show interfaces transceiver actual 
  Slot/Port   Temp (C)   Voltage (V)   Current (mA)   Output (dBm)   Input (dBm)  
------------+----------+------------+--------------+--------------+-------------
    1/1        45.0        3.317        6.626         -5.667           -Inf    
    1/3        42.0        3.315        6.614         -5.766           -Inf    
    1/10       38.0        3.318        6.424         -5.781           -Inf    
    1/17       44.0        3.314       16.464         17.927(AH)     -7.879  

test cihazımız üzerinden interfacelerin ddm özelliklerini listeleyelim. RX değerleri switch üzerinden şimdide snmp ile alalım. bunun için ddmRxOpticalPower objesine karşılık gelen değeri biliyor olmamız gerek. bu değer bu cihazda

enterprises.6486.800.1.2.1.5.1.1.2.5.1.21
1.3.6.1.4.1.6486.800.1.2.1.5.1.1.2.5.1.21

şeklinde. bu değeri ögrendikten sonra gerekli veriyi alalım.

$ snmpwalk -v 2c -c public 10.0.0.10  1.3.6.1.4.1.6486.800.1.2.1.5.1.1.2.5.1.21
SNMPv2-SMI::enterprises.6486.800.1.2.1.5.1.1.2.5.1.21.1001 = INTEGER: -2147483648
SNMPv2-SMI::enterprises.6486.800.1.2.1.5.1.1.2.5.1.21.1003 = INTEGER: -2147483648
SNMPv2-SMI::enterprises.6486.800.1.2.1.5.1.1.2.5.1.21.1010 = INTEGER: -2147483648
SNMPv2-SMI::enterprises.6486.800.1.2.1.5.1.1.2.5.1.21.1017 = INTEGER: -7879

yukarıdaki çıktıdan görüldüğü gibi dönen değerler ile cli üzerinden sorğuladığımız değerler kısmen alakalı görülüyor ancak %100 aynı değil. bu değerleri doğru şekilde yorumlayabilmek için alcatelin sayfasından indirdiğimiz mib dosyalarına ihtiyacımız olacak. bu dosyalara baktığımızda ddmRxOpticalPower objesi için aşağıdaki bilgi yer alıyor..

ddmRxOpticalPower              OBJECT-TYPE
    SYNTAX      Integer32 (-200000 | -40000..10000)
	UNITS       "thousandth of a dBm"
    MAX-ACCESS  read-only
    STATUS      current
    DESCRIPTION
        "The value of ddmRxOpticalPower indicates the current Received
         Optical Power of the SFP/XFP in 1000s of dBm.
		 A value of -200000 indicates this object is not applicable."
    ::= { ddmInfoEntry 21 }

yani bir nms uygulaması yazıyorsak elde edilen değeri 1000 e bölmemiz ve çıkan değer (-200000 | -40000..10000) dışında ise geçerli bir değer olmadığını bilmeliyiz.

DDM (Diagnostic Monitoring Interface)

DDM (Diagnostic Monitoring Interface) SFF Committee tarafından standart hale getirilmiş Transceivers lerin isminde de anlaşılacağı üzere verilerini monitör etmekte kullanılmaktadır.

işin detayını merak ediyorsanız http://www.sffcommittee.org adresini ziyaret etmeyle başlayabilirsiniz. piyasadaki bir çok farklı farka ve model transceiver bu standart daki yer alan tüm özellikleri desteklemeyebilir.

cisco, alcatel gibi bazı firmalar doğrudan bu standarttı takip etmemektedir. özellikle bu firmaların ürünleri ile çalışırken transceiver ile switch-router uyumuna dikkat edilmelidir. yine piyasadaki bir çok ürün bu standarttaki tüm özelliklerin hepsini içermeyebilir. kullanılacak duruma göre buna dikkat edilmelidir.

ftp://ftp.seagate.com/sff/SFF-8472.PDF

adresinden güncel standart dokümanına erişebilirsiniz.

ddm in aktif olması ve izlenmesi bir çok hata tespitinde ve giderilmesinde kullanılmaktadır. sitede huawei ve alcatel cihazlarla ilgili örnekler bulabilirsiniz.

huawei – iki switch arasi statik route

elimizde s5700 serisi iki adet huawei switch olduğunu düşünelim. switchlerimizi aşağıdaki topolojiye uygun olarak fiziksel bağlantılarını gerçekleştirelim.

 

basit_switch_ornek1

fiziksel bağlantıların doğru olup olmadığını “diplay interface brief” ile kontrol edebilirsiniz. bu komutun çıktısı aşağıdakine benzer olacaktır. her iki switchde gerekli bağlantıları kontrol ettikten sonra en temel tanımlamalarımızı yapmaya başlayalım.

bu örnekte ofis_a ve ofis_b switchine gerekli tanımlamaları eş zamanlı girildiği belirtmekte fayda var.

InUti/OutUti: input utility/output utility
Interface                   PHY   Protocol InUti OutUti   inErrors  outErrors
GigabitEthernet0/0/1        up    up          0%     0%          0          0
GigabitEthernet0/0/2        up    up          0%     0%          0          0
GigabitEthernet0/0/3        down  down        0%     0%          0          0
GigabitEthernet0/0/4        down  down        0%     0%          0          0
GigabitEthernet0/0/5        down  down        0%     0%          0          0

cihazlarımızı karıştırmamak için öncelikle cihazlarımıza birer ad verelim. bunun için “sysname sistem_adi” komutu kullanılacaktır.

system-view 
Enter system view, return user view with Ctrl+Z.	
[Huawei]sysname ofis_b
[ofis_b]

switch yönetimi ve 10.0.0.1/24 için 100 vlanı kullanacağız. ofis_b switch için gerekli tanımlamaları adım adım girelim.

vlan 100 i switch üzerine ekleyerek ip adresini ekleyelim

[ofis_b]vlan batch 100
[ofis_b]interface Vlanif 100
[ofis_b-Vlanif100]ip address 10.0.0.2 24
[ofis_b-Vlanif100]display this
#
interface Vlanif100
 ip address 10.0.0.2 255.255.255.0
#
return
[ofis_b-Vlanif100]quit

şimdi gerekli statik route u yazalım.

[ofis_b]ip route-static 0.0.0.0 0.0.0.0 10.0.0.1

route için gerekli kontrolleri yapalım..

[ofis_b]display ip interface brief 
*down: administratively down
^down: standby
(l): loopback
(s): spoofing
The number of interface that is UP in Physical is 2
The number of interface that is DOWN in Physical is 2
The number of interface that is UP in Protocol is 1
The number of interface that is DOWN in Protocol is 3

Interface                         IP Address/Mask      Physical   Protocol  
MEth0/0/1                         unassigned           down       down      
NULL0                             unassigned           up         up(s)     
Vlanif1                           unassigned           up         down      
Vlanif100                         10.0.0.2/24          down       down  
   

yukarıda 100 vlanın eklendiğini ve 10.0.0.2/24 in fiziksel ve protokol olarak down olduğu görülmekte. yani sıra fiziksel arayüz tanımlamaları yapmaya geldi demek.

[ofis_b]nterface GigabitEthernet 0/0/1
[ofis_b-GigabitEthernet0/0/1]description ofis_a—ofis_b
[ofis_b-GigabitEthernet0/0/1]port link-type trunk
[ofis_b-GigabitEthernet0/0/1]port trunk allow-pass 100
[ofis_b-GigabitEthernet0/0/1]quit


0/0/1 portunu trunk mode olarak ayarladık ve 100 vlanı bu porta tanımladık. şimdi gerekli kontrolleri yapalım.


[ofis_b]display ip interface brief 
*down: administratively down
^down: standby
(l): loopback
(s): spoofing
The number of interface that is UP in Physical is 2
The number of interface that is DOWN in Physical is 2
The number of interface that is UP in Protocol is 1
The number of interface that is DOWN in Protocol is 3

Interface                         IP Address/Mask      Physical   Protocol  
MEth0/0/1                         unassigned           down       down      
NULL0                             unassigned           up         up(s)     
Vlanif1                           unassigned           up         down      
Vlanif100                         10.0.0.2/24          up         up   
  

buradan görüldüğü üzere 100 vlani fiziksel ve protokol olarak up görülmektedir.

sıra geldi en temel kontrole

[ofis_b-GigabitEthernet0/0/1]ping 10.0.0.1
  PING 10.0.0.1: 56  data bytes, press CTRL_C to break
    Reply from 10.0.0.1: bytes=56 Sequence=1 ttl=255 time=50 ms
    Reply from 10.0.0.1: bytes=56 Sequence=2 ttl=255 time=30 ms
    Reply from 10.0.0.1: bytes=56 Sequence=3 ttl=255 time=50 ms
    Reply from 10.0.0.1: bytes=56 Sequence=4 ttl=255 time=50 ms
    Reply from 10.0.0.1: bytes=56 Sequence=5 ttl=255 time=10 ms

ofis_a swith konfigürasyonu

ofis_b swith konfigürasyonu

huawei quidway ekipmanlarında arayüz konfigürasyonun temizlenmesi

cli üzerinden tanımlama yapanların en sinir olduğu konulardan birisidir kullanılması gereken arayüzler de geçmişte yapılan tanımların kırıntıların kalması ve bunların temizlenmesidir. kimi üreticilerin bu gibi durumlarda çözümleri olmasa da huawei firmasının quidway serisi gibi cihazların üzerindeki os lar buna izin verebilmekte..

quidway serisi cihazlarda bunun için cli da clear komutunu kullanıyoruz. genel kullanımı aşağıdaki gibi. komutu girdikten sonra bizden konfigürasyonu silip portu kapatılması yönünde onay alınacak.

[quidway-test] clear configuration interface gigabitethernet 1/1/1
Warning: All configurations of the interface will be cleared, and its state will be shutdown. Continue? [Y/N]: Y

gerekli onay işlemini verdikten sonra bize aşagıdaki şekilde bir bilgi satırı gelecektir. interface içine girerek mevcut konfigürasyonuna baktığımızda konfigürasyonun silindiğini ve interface in kapatıldığını görürüz.

Info: Total execute 7 command (s), 7 successful, 0 failed. – this will prompt a total removal of 7 configuration interface

[quidway-test] interface gigabitethernet 1/1/1
[quidway-test-GigabitEthernet1/1/1] display this
#
interface GigabitEthernet1/1/1
shutdown

huawei s5300 serisi switchlerde optik arayüzün değerleri

[huawei-s5300-GigabitEthernet0/0/5]display transceiver diagnosis interface GigabitEthernet 0/0/5
Port GigabitEthernet0/0/5 transceiver diagnostic information:
Parameter        Current     Low Alarm    High Alarm
  Type            Value      Threshold    Threshold    Status
-------------   ---------    ---------    ----------   --------
TxPower(dBm)    -5.92        -8.99        -2.99        normal
RxPower(dBm)    -4.74        -17.00       -5.00        abnormal
Current(mA)     13.27        1.00         50.00        normal
Temp.(C)        32.53        0.00         80.00        normal
Voltage(V)      3.31         3.10         3.50         normal

buradan görülebileceği gibi RX değerleri normal değerlerin üzerinde. Fiziksel kontrol gerekmektedir. En iyi olasılık optik zayıflatıcı kullanmak.

Back To Top